Can't Connect to Battlenet on Lordaeron (US West) server

Off-Topic conversations, forum games, fun topics and pretty much anything else that doesn't fit into any other forum.
User avatar
WharfRat
Posts: 5
Joined: Sun Jan 08, 2017 10:32 pm

Can't Connect to Battlenet on Lordaeron (US West) server

Postby WharfRat » Mon Sep 18, 2017 11:58 am

Hello everyone,

In the past couple of days I've reinstalled WC3 for the explicit purpose of WW Trans. I've played 2 games - one of which was about 8 hours ago.

I have just tried to logon to the Lordaeron (US West) server and once I enter my password and press login, the screen does not change aside from all the buttons greying out except for Cancel. I have restarted my computer, launched in admin mode, but the problem persists.

To test, I made a new account on another realm, and it let me log in.

Does anyone know what this issue may be? Is it related to my account or the server?

Thank you :)
User avatar
Falanor
Posts: 224
Joined: Sat Apr 23, 2016 5:04 pm

Re: Can't Connect to Battlenet on Lordaeron (US West) server

Postby Falanor » Mon Sep 18, 2017 1:15 pm

Never experienced anything like that tbh. Did you try reinstalling the game? It takes only 10-15 min on modern computers and usually solves all the problems.
benwoaa
Posts: 5
Joined: Wed Jun 28, 2017 7:02 pm
Location: Amsterdam

Re: Can't Connect to Battlenet on Lordaeron (US West) server

Postby benwoaa » Mon Sep 18, 2017 5:16 pm

Just checking ... you were not using a VPN at the same time? I only have this issue when I forget to switch off my VPN.
User avatar
WharfRat
Posts: 5
Joined: Sun Jan 08, 2017 10:32 pm

Re: Can't Connect to Battlenet on Lordaeron (US West) server

Postby WharfRat » Mon Sep 18, 2017 11:49 pm

I was not using a VPN.

I suppose I posted too soon though because a couple of hours later I tried and it worked again.

Thank you for the suggestions though.